🏠 FabLab Startseite | Nutzungsbedingungen | Impressum | Wiki

Umbau 3D Drucker auf Ramps 1.4 Board - Unterstützung gesucht


#1

Hallo,
ich möchte meinen Velleman K8200 auf ein Ramps 1.4 Board umbauen.
Die Originalboards sind extrem störanfällig. 2 sind mir schon durchgebrannt.
Die benötigten Materialien sind soweit vorhanden. Irgendwie habe ich mich
aber alleine nie daran getraut das Projekt umzusetzen.
Ich habe mir letzten Freitag das Lab schon einmal ansehen dürfen und habe
mir gedacht, dass das die richtige Umgebung für mein Umbauprojekt wäre.
Vielleicht hat ja schon jemand Erfahrung mit dem Ramps 1.4 und der entsprechenden Firmware.
Softwaretechnisch wollte ich bei der Gelegenheit auf Cura umsteigen.


Hier ein Bild aus meinem Keller.

Gruß
André


#2

Moin,
Ich stecke gerade in selben Projekt und kommt mittlerweile mit dem Board einigermaßen klar.
Da könnte ich dir durchaus helfen.
Ich kenne auch noch jemanden der Profi auf dem Gebiet ist, vielleicht hat der auch Zeit Freitag da zu sein.

Gruß
Christian


#3

Super.
Ich bringe Freitag einfach mal ein paar Sachen mit und dann können wir ja mal schnacken.

Gruß
André


#4

Hey Andre,
bin gespannt ob der Drucker nächsten Freitag läuft… Ich drück die Daumen.
Jedesmal spannend. Hab auch noch einen Kandidaten zu Hause stehen, wo nur noch das Board eingebaut werden muss, Firmware drauf und “Kleinigkeiten” anpassen…

Viele Grüße,
Philip


#5

Ich habe dem Drucker erst einmal eine stabile Plattform verpasst. Das erleichtert das weitere Arbeiten, den Transport und dämpft einiges an Schwingungen weg.
Das Board folgt dann in den nächsten Tagen. Ich hoffe auch das ich das zu Freitag hin bekomme.
Mache alles so wie Familie und Arbeit Zeit dafür lassen.

Gruß
André


#6

Vielen Dank noch mal an Christian - Ohne die Hilfe wäre ich noch lange nicht so weit.

Nach dem ich nun die Hälfte der Kabel/Stecker umgelötet habe, habe
ich vorhin mal den ersten Versuch gestartet. Die Achsen laufen schon mal in die Richtige Richtung.
Endstops funktionieren auch schon. Extruder heizt. Temperaturen werden korrekt angezeigt.
Extrudermotor und Heizbett streiken noch. Allerdings hatte ich auch nur einen Stromkreis angeschlossen :roll_eyes: Die Anschlusspunkte für den Lüfter such ich noch.
Tolle Hilfe ist die Seite Chinadrucker.

“Alles wird gut!”


#7

Kleines Update.
Heizbett funktioniert. Temperaturen werden auch sauber angezeigt.
Aber leider kein Signal für den Extrudermotor. Motor und Verkabelung sind geprüft und ok.
Als nächstes also noch mal an die Firmwareeinstellungen.


#8

Wenn man mal auf das Diagramm von http://reprap.org/wiki/RAMPS_1.4 schaut gibt es für den Lüfter mehrere Möglichkeiten.


Man kann zum Beispiel den D9 Anschluss verwenden um einen Lüfter zu steuern. Der muss aber Im Programm dafür aktiviert werden. Einfacher ist es da die beiden Pins neben dem X Treiber zu nutzen. Dort liegen 12V an.
Eine weitere Möglichkeit wäre es einen der Ungenutzten Pins im Programm neu zu belegen und dann damit einen Lüfter zu steuern.
Als Extruder ist normalerweise nur E0 aktiv, außer im Programm steht es anders.

Hoffe mal das hilft.


#9

Hallo,
mich würde der Umbau auch interessieren… :slight_smile:


#10

Der Vellemann lief mit dem Ramps Board ganz ordentlich. Dank der Hilfe von Jake, Marcel und Kevin.
Inzwischen liegt das Projekt aus Zeitmangel bei mir auf Eis.
Die Technik hat meine 2 Vellemann Drucker überholt und sie stehen nur noch rum. Gehen wahrscheinlich bald in den Verkauf.
Aktuell drucke ich auf meinem RF100, CR10, Makerbot (muss auch repariert werden) und mit dem Delta XL von meinem Sohn. 6 Drucker zu Hause sind langsam etwas viel und ich bekomme Ärger mit der Regierung :stuck_out_tongue_winking_eye:
Auch habe ich noch das Material für einen Cubus mit 400x400x400 Bauraum liegen.